
 

Animasi Sederhana dengan Macromedia Flash 1111 

MACROMEDIA FLASH 

Macromedia flash/Adobe Flash adalah perangkat lunak aplikasi untuk pembuatan animasi 

yang digunakan untuk halaman web. Macromedia flash mampu melengkapi website dengan 

beberapa macam animasi interaktif. Penggunaan flash merupakan hal biasa dalam 

pengembangan web site, namun flash hanya digunakan sebagai pelengkap dalam 

pengembangan web dinamis, seperti animasi dan aplikasi client-side interaktif. 

 Sedangkan Animasi adalah sebuah rangkaian gambar yang disusun secara berurutan. 

Ketika rangkaian gambar tersebut ditampilkan dengan kecepatan yang memadai, maka 

rangkaian gambar tersebut akan terlihat bergerak. 

1.1 Mengenal interface Macromedia Flash 8 
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Interface Macromedia Flash terdiri dari beberapa bagian antara lain: 

1. Menu Bar 

Menu bar merupakan barisan menu yang berisi kumpulan perintah yang digunakan 

pada Macromedia Flash 8. 

2. Tool Panels 

Tool Panels merupakan barisa menu yang ditandai dengan berbagai ikon. Merupakan 

jalan pintas untuk menjalankan menu. 

3. Stage 

Merupakan bagian dari Macromedia flash yang digunakan untuk membuat atau 

meletakkan objek. 

4. Timeline 

5. Berisi berbagai frame yang berfungsi mengontrol objek yang dianimasikan. 

a. Layer 

Merupakan susunan atau lapisan yang terdiri dari kumpulan objek atau 

komponen gambar, teks, atau animasi. 

b. Frame 

Merupakan bagian yang terdii dari berbagai segmen yang akan dijalankan 

secara bergantian dari kiri ke kanan. 

c. Playhead 

Merupakan penunjuk posisi frmae pada saat dijalankan. 

 

 

 

 
6. ToolBox 

Yang terdiri dari bermacam tool yang berfungsi membuat gambar, memilih objek dan 

memanipulasikan objek yang merupakan komponen dari stage. 

a. Tools 

Merupakan bagian dari komponen yang berfungsi untuk membuat gambar, 

memilih objek dan memanipulasikan objek. 

b. View 

Digunakan untuk mengatur tampilan stage. 

 

Layer Frame Playhead 
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c. Colors 

Digunakan untuk mengatur atau memanipulasikan pewarnaan objek. 

d. Options 

Merupakan bagian dari toolbox yang akan tampil pada saat anda mengaktifkan 

salah satu ikon dari toolbox. 

   Tools View       Colors Options 

            
 

7. Panels 

Nyang berfungsi untuk mengontrol atau memodifikasi berbagai atribut pada objek 

atau animasi secara cepat. 

a. Properties 

Panel yang berfungsi untuk emngatur property objek yang aktif. 

 
b. Action 

Panel yang berfungsi untuk memberikan aksi atau kerja terhadap suatu objek 

pada stage, frame atau layer. 
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c. Color 

Panel yang berfungsi untuk mengatur pewarnaan terhadap suatu objek secara 

lebih detail. 

 
d. Library 

Panel yang digunakan sebagai tempat penyimpanan objek yang telah dibuat di 

stage. 

 
1.2 Membuat Dokumen Baru 

a. Pilih Menu File > New. 

b. Pada kotak dialog new document , secara default Flash Document dalam keadaan 

terseleksi. 

c. Klik OK 
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d. Pada bagian property inspector, tombol size menampilkan ukuran dokumen yang 

defaultnya 550 * 440 pixels 

 
Warna background defaultnya adalah putih. Lalu rubahlah warna tersebut menjadi 

warna yang anda inginkan.Misalkan warna Hitam. 

 

1.3 Menggambar Objek 

Setelah berhasil membuat dokumen, sekarang akan menambahkan objek 

gambar pada dokumen. Langkah-langkahnya adalah sebagai berikut: 

a. Pada area layer name, klik ganda Layer 1, dan ubah namanya menjadi layer Bar. 

 menjadi  

b. Seleksilah pada Rectangle Tool pada Tool Panel 

 
Pilih opsi No Color dari Stroke Color Picker 
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c. Pilih warna yang anda inginkan untuk kotak Fill Color. Pilih saja warna biru 

karena akan jelas terlihat. 

 
d. Sekarang arahkan mouse kea rah stage, lalu buat gambar persegi dengan menarik 

sampai mendapatkan gambar seperti dibawah ini. 

 
Dengan warna background hitam: Fill Color warna Biru, Stroke Color tidak ada 

warna. 

 

1.4 Membuat Objek Tombol 

Setelah memiliki bar, sekarang kita akan menambahkan tombol pada bar tersebut. 

1. Buat layer baru di atas layer bar, lalu ubah namanya menjadi layer Tombol. 

 
 

2. Pilih opsi No Color dari Stroke Color Picker. 

 
 

3. Pilih warna yang anda inginkan untuk kotak fill color. Misalnya warna merah 
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4. Sekarang seleksilah tombol Oval Tool pada tool panel  

 
5. Pastikan layer tombol dalam keadaan terseleksi, arahkan mouse kea rah stage, 

tarik untuk membuat bentuk elips. 

6. Posisikan gambar elips pada bar. 

 

 

1.5 Membuat Tombol  

Anda dapat menggunakan gambar untuk digunakan berulang-ulang dengan 

mengonversikan menjadi Symbol. Symbol adalah asset yang dapat dipake secara 

berulang pada setiap dokumen flash tanpa perlu membuat ulang. 

1. Klik Selection Tool pada Tool Panel 

 
2. Klik gambar elips pada stage untuk menyeleksi 

3. Pastikan gambar elips dalam keadaan terseleksi, tekan menu Modify > 

Convert to Symbol. 

4. Pada kotak dialog Convert to Symbol, ketikkan Tombolku pada kotak name 

text box, dan behavior pilihlah Button. 

 
5. Klik OK. 

6. Symbol yang anda buat akan terlihat pada panel library (tekan menu windows 

> Library untuk membukanya.) 
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1.6  Menganimasikan Tombol  

Sekarang kita akan menganimasikan tombol agar terlihat lebih menarik dan 

interaktif. 

a. Klik ganda gambar elips pada stage. Langkah in akan membuka ruang editing 

untuk tombol. 

 
b. Arahkan mouseanda ke event Over pada area layer, klik kanan lalu pilih insert 

Keyframe.  

 
c. Sekarang klik pada Keyframe Over yang telah anda buat. Arahkan mouse ke 

gambar elips pada stage, klik kanan, lalu pilih Convert to Symbol. 

 

d. Pada kotak dialog Convert to Symbol, ketikkan Tombol_animasi pada kotak 

Name text box dan behavior-nya pilih Movie. 
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e. Sekarang klik ganda pada gambar elips untuk beralih ke ruang editing movie 

tombol 

 
f. Arahkan mouse ke frame 5, klik kanan, lalu pilihlah Insert Frame. 

 
g. Arahkan mouse ke sepanjang farme 1 sampai frame 5, klik kanan, lalu pilih 

Create Motion Tween. 

 
h. Sekarang arahkan mouse ke frame 5, klik kanan, lalu pilih Insert Keyframe. 

 
i. Sekarang klik frame 1 untuk menyeleksinya. 

j. Klik gambar elips pada stage. 

k. Pada Property Inspector, untuk Color Type, pilihlah Alpha dan persentasenya 

dijadikan 50%. 

 
l. Klik tombol Scene 1 untuk kembali ke ruang edit utama 
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 menjadi  

m. Tekan enter dan ctrl, untuk melihat tampilan tombol Anda. Pada jendela 

preview, arahkan mouse ke atas tombol elips dan lihatlah animasinya. 

   Menjadi   

 

1.7 Mempublikasikan File 

Setelah selesai dengan semua pekerjaan pada dokumen, langkah terakhir yang 

harus anda lakukan adalah mempublikasikan file anda agar dapat terbuka pada 

browse. 

Langkah-langkahnya adalah sebagai berikut: 

a. Tekan menu File > Save, lalu simpan file pada tempat yang anda inginkan. 

b. Tekan menu File > Publish Settings 

c. Pada kotak dialog Publish Settings, klik tab Formats dan pastikan hanya opsi Flash 

dan HTML saja yang terseleksi. 

 
d. Pastikan kotak dialog Publish Settings, klik pada tab HTML dan pastikan pilihan 

Flash Only terseleksi pada pop-up menu template. 
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e. Klik OK untuk menyimpan settingan atau klik Publish untuk menyimpan settingan 

dan mempublikasikan file anda. 

 

Dasar Pembuatan Animasi Flash 
Cara kerja naimasi tergantung dari pengaturan frame pada layer. Panjang pendeknya 

frmae sangat mempengaruhi kecepatan gerakan objek yang dianimasikan. Animasi yang 

cepat dibuat pada Macromedia flash dapat dibedakan menjadi beberapa jenis, diantaranya 

adalah: 

a. Animasi Frame by Frame 

b. Animasi Motion Tween 

c. Animasi Shape Tween 

d. Animasi Color Tween 

 

1. Animasi Frame by Frame 

Animasi ini adalah animasi yang dibuat hanya dengan menggunakan berbagai 

frame dalam satu layer ataupun antar layer. Lama tidaknya sebuah animasi 

dijalankan sangat tergantung dari jumlah frame. 

 

Animasi Teks  

Animasi teks adakag animasi menggunakan objek teks. Langkah-langkahnya 

adalah sebagai berikut: 
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a. Buka lembar kerja baru 

b. Klik ikon   pada toolbox, kemudian ketik “TOKO ONLINE” pada 

stage. Atur setting teks pada panel Properties. Jenis font: Wide Latin, 

ukuran huruf 30 dan pilih warna huruf merah. 

 
c. Klik kanan pada teks “ TOKO ONLINE” kemudian pilih menu Copy. 

d. Setelah itu, klik kanan pada frame 3. Pilih Insert Blank Keyframe untuk 

menambahkan frame kosong. 
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e. Klik kanan pada stage kosong, pilih menu Paste In Place. 

 
f. Selanjutnya ubahlah warna huruf menjadi warna merah muda. 

 
g. Berikutnya, klik kanan pada frame 6, lalu pilih Insert Blank keyframe. 

h. Klik kanan pada stage kosong, dan pilih menu Paste in Place. 

i. Ubah warna teksnya menjadi warna hijau. 

j. Selanjutnya, klik kanan pada frame 9, lalu pilih Insert Blank keyframe. 

k. Klik kanan pada stage kosong, dan pilih menu Paste in Place. 

l. Ubah warna teks menjadi warna orange. 

m. Ulangi langkah  no. 10 – 12 untuk frame 12 dan frame 15 

n. Setelah selesai, lakukan test movie dengan menekan kombinasi tombol 

CTRL + Enter. 

 

Animasi Teks 2 

Animasi Teks kategori frame by frame berikutnya ini adlaah animasi 

teks yang muncul huruf per huruf. Langkahnya adalah sebagai berikut: 

1. Buka lembar kerja baru 

2. Klik ikon   pada toolbox, atur setting huruf seperti berikut. 
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3. Berikutnya, ketik huruf T pada stage. 

T
 

4. Kik frame 3, lalu pada baris menu klik Insert > Timeline > Keyframe. 

5. Klik ikon , kemudian klik huruf T pada stage dan tambahkan huruf O 

dengan warna merah. 

 
6. Klik frame 5, lalu pada baris menu klik Insert > timeline > Keyframe. 

7. Klik ikon , kemudian klik huruf TO pada stage dan tambahkan huruf K 

dengan warna Hijau. 

 
8. Klik frame 7, lalu pada baris menu klik Insert > timeline > Keyframe. 

9. Klik ikon , kemudian klik huruf TOK pada stage dan tambahkan huruf 

O dengan warna Biru. 

 
10. Klik frame 9, lalu pada baris menu klik Insert > timeline > Keyframe. 

11. Klik ikon , kemudian klik huruf TOKO pada stage dan tambahkan 

huruf O dengan warna Merah Jambu. 

 
12. Klik frame 11, lalu pada baris menu klik Insert > timeline > Keyframe. 

13. Klik ikon , kemudian klik huruf TOKO O pada stage dan tambahkan 

huruf N dengan warna Merah Hitam. 

 
14. Klik frame 13, lalu pada baris menu klik Insert > timeline > Keyframe. 
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15. Klik ikon , kemudian klik huruf TOKO ON pada stage dan tambahkan 

huruf L dengan warna Kuning. 

 
16. Klik frame 15, lalu pada baris menu klik Insert > timeline > Keyframe. 

17. Klik ikon , kemudian klik huruf TOKO ONL pada stage dan 

tambahkan huruf O dengan warna Hijau Tua. 

 
18. Klik frame 17, lalu pada baris menu klik Insert > timeline > Keyframe. 

19. Klik ikon , kemudian klik huruf TOKO ONLI pada stage dan 

tambahkan huruf O dengan warna Merah. 

 
20. Klik frame 19, lalu pada baris menu klik Insert > timeline > Keyframe. 

21. Klik ikon , kemudian klik huruf TOKO ONLIN pada stage dan 

tambahkan huruf O dengan warna Ungu. 

 
22. Setelah selesai, lakukan test movie dengan menekan kombinasi tombol 

CTRL + Enter. 

 

Animasi Motion Tween 

 Animasi motion tween merupakan bentuk animasi yang paling 

mendasar pada macromedia flash. Animasi ini digunakan untuk menggerakan 

objek dari satu titik ke titik lain. Berikut adalah contoh dari animasi ini. 

 

Animasi Objek Bergerak 

1. Buka lembar kerja baru. 

2. Berikutnya, klik ikon  pada toolbox dan buat objek segiempat pada 

stage. 

3. Klik frame 15 dan klik menu Insert > Timeline > Keyframe. 

4. Kemudian, klik ikon  pada toolbox, dan pindahkan objek segiempat ke 

sisi kanan. 
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5. Selanjutnya, klik frame 30 dan kik menu Insert > Timeline > Keyframe. 

6. Kemudian, klik ikon  pada toolbox, dan pindahkan objek segiempat ke 

sisi Kiri. 

 
7. Klik Layer 1 untuk mengaktifkan frame 1 sampai dengan frame 30 

8. Kemudian, klik menu Insert > Timeline > Create motion Tween. 

9. Terakhir, lakukan Test Movie dan tekan kombinasi tombol CTRL + Enter 

 

Animasi Shape Tween 

Animasi ini sering disebut juga animasi bentuk atau animasi perubahan 

bentuk. Dalam pembuatan animasi ini dibutuhkan banyak Blank Keyframe, 

yaitu sebuah frame kosong yang akan digunakan untuk menambahkan bentuk 

objek yang berbeda pada keyframe sebelumnya. 

 

1. Animasi perubahan bentuk lingkaran menjadi bentuk 

segiempat 

Cara membuatnya adalah sebagai berikut. 

a. Buka lembar kerja baru yang kosong 
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b. Berikutnya, klik ikon  pada toolbox, lalu atur setting warna 

stroke dengan warna hijau dengan ketebalan garis (height 

color): 14 dan warna fill kuning. 

c. Setelah itu, buat objek lingkaran pada stage. 

 
d. Selanjutnya, tambahkan frame kosong pada posisi frame 10 

dengan mengklik frame 10. Kemudian, klik menu Insert > 

Timeline > Blank Keyframe. 

e. Klik ikon   pada toolbox, lalu atur setting warna stroke 

dengan warna orange dengan ketebalan garis(heigt color): 14 

dan warna fill merah. 

 
f. Klik layer 1 untuk mengaktifkan frame 1 sampai frame 10, 

kemudian pada panel properties pilih shape pada option tween 
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Setelah anda menentukan Shape Tween, pada frame ajan 

terlihat anak panah berwarna hijau muda. 

 
g. Sebagai tahap akhir, lakukan tes movie dengan menekan 

CTRL + Enter. 

 

Animasi Color Tween 

 Animasi ini adlaah animasi warna pada macromedia flash. Hasil 

akhirnya adalah perubahan warna atau kesan menghilang/kabur pada objek 

yang dianimasikan. 

Animasi Brightness 

Hasil akhirnya adlaah memudar menjadi warna putih. Langkah-

langkahnya adalah sebagai berikut. 

1. Buka lembar kerja baru. 

2. Selanjutnya, klik menu File > import > Import to the Stage 

untuk mengambil foto dari direktori lain. Setelah itu klik open. 
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3. setelah objek foto tampil di satge, atur ukuran dan posisi objek 

foto pada panel properties. W = 200, H = 200, x = 160, Y = 100. 

 
4. Agar objek foto dapat ditambahkan animasi color tween, 

konversikan objek foto, lalu pilih menu Convert to Symbol. 

5. Setelah tampil kotak Convert to Symbol, beri nama Foto 1, lalu 

pilih tipe Movie Clip. 

 
6. Setelah itu ganti nama layer 1 menjadi foto 1. 

7. Tambahkan layer baru dengan mengklik ikon  pada kolom 

layer, lalu ganti nama menjadi foto 2 

8. Klik menu File > Import > Import to the Stage 

9. Pilih direktori foto yang ingin ditampilkan. 

10. Selanjutnya, atur setting ukuran dan posisi foto pada panel 

properties 

11. Klik mouse kanan dan pilih Convert to Symbol. 

.   

12. Setelah itu ganti nama layer 3 menjadi foto 3. 

13. Tambahkan layer baru dengan mengklik ikon  pada kolom 

layer, lalu ganti nama menjadi foto 3 

14. Klik menu File > Import > Import to the Stage 

15. Pilih direktori foto yang ingin ditampilkan. 

16. Selanjutnya, atur setting ukuran dan posisi foto pada panel 

properties 

17. Klik mouse kanan dan pilih Convert to Symbol. 
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18. Atur fotonya menjadi seperti dibawah ini. 

 
19. Selanjutnya, klik frame 10 layer Foto 1 dan klik menu Insert > 

Timeline > keyframe. 

20. Klik frame 20, lalu klik menu Insert > timeline > Keyframe. 

21. Selanjutnya, klik frame 10 layer Foto 2 dan klik menu Insert > 

Timeline > keyframe. 

22. Klik frame 20, lalu klik menu Insert > timeline > Keyframe. 

23. Selanjutnya, klik frame 10 layer Foto 3 dan klik menu Insert > 

Timeline > keyframe. 

24. Klik frame 20, lalu klik menu  Insert > timeline > Keyframe. 

  
25. Pada langkah berikutnya, aktifkan semua layer dengan menekan 

SHIFT pada layer Foto 1 sampai dengan Foto 3. 

26. Selanjutnya, klik menu  Insert > Timeline > Create Motion 

Tween. 
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27. Tambahkan layer baru dengan mengklik  lalu ganti nama layer 

baru dengan nama Border. 

28. Pindahkan posisi layer Border diatas Layer Foto 1. 

29. Klik layer foto 2 untuk mengaktifkan frame 1-20 layer foto 2, lalu 

drag dan pindahkan pada posisi frame 20. 

 
30. Klik layer foto 2 untuk mengaktifkan frame 1-20 layer foto 3, lalu 

drag dan pindahkan pada posisi frame 40. 

 
31. Aktifkan layer Border, klik pada frame 58 dan insert > timeline > 

Frame. 

32. Pada tahap selanjutnya, klik frame 1 layer Border, serta 

tambahkan variasi border dengan mengklik ikon . Atur setting 

garis stroke pada panel properties dengan setting Stroke Height = 

20, warna stroke no color dan pilihlah salah satu bentuk garis pada 

Stroke Style. 

33. Jalankan pada tes movie dengan menekan CTRL + Enter. 

 
 


